MUI on Windows Server 2008 R2

Today I tried to install a Language Pack (KB974587) on a Windows Server 2008 R2. This failed silently, but I found a hint in the Logfiles (C:\Windows\Logs\CBS\CBS.log):

2012-07-28 18:24:50, Info                  CSI    000005f7 Begin executing advanced installer phase 34 (0x00000022) index 4105 (0x0000000000001009) (sequence 4137)
    Old component: [l:0]""
    New component: [ml:324{162},l:322{161}]"Microsoft-Windows-WCFCoreComp.Resources, Culture=de-de, Version=6.1.7600.16385, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=amd64, versionScope=NonSxS"
    Install mode: install
    Installer ID: {d82eedee-854e-4f9a-b458-ae1bc62a0e6b}
    Installer name: [16]"LodCtr Installer"
2012-07-28 18:24:50, Error                 CSI    00000022 (F) Logged @2012/7/28:16:24:50.996 : [ml:456{228},l:454{227}]"Cannot open actual INI file "C:\Windows\inf\ServiceModelService 3.0.0.0\_ServiceModelServicePerfCounters.ini" referenced in "C:\Windows\inf\ServiceModelService 3.0.0.0\0407\_ServiceModelServicePerfCounters_D.ini", error code 2."
[gle=0x80004005]

The ServiceModelService belongs to the WCF part of the .NET Framework. In the Server Manager under Features I found the “WCF-Activation” option. So I activated this option (with “Non-HTTP Activation”). Afterwards, the file in Question existed and the installation of the Language Pack succeeded!

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>